<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="profile" href="https://gmpg.org/xfn/11" />
  <link rel="pingback" href="https://rpgamer.com/xmlrpc.php">

  <title>RPG Cast &#8211; Episode 557: &#8220;PS5 Crunchwrap Supreme!&#8221; &#8211; RPGamer</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/rpgamer.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://rpgamer.com/wp-includes/css/dist/block-library/style.min.css?x89916&amp;ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='foobox-noie7-min-css'  href='https://rpgamer.com/wp-content/plugins/foobox-image-lightbox-premium/pro/css/foobox.noie7.min.css?x89916&amp;ver=2.7.11' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar_releases.css-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/template_css/sidebar_releases.css?x89916&amp;ver=3.3.28.c1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='poll.css-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/template_css/poll.css?x89916&amp;ver=3.3.28.c1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css'  href='https://rpgamer.com/wp-content/themes/hueman/assets/front/css/main.min.css?x89916&amp;ver=3.3.28.c1.9.6' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:Verdana, sans-serif;font-size:0.75rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.75rem; }
      }.container-inner { max-width: 1120px; }.sidebar .widget { padding-left: 20px; padding-right: 20px; padding-top: 20px; }::selection { background-color: #c18d34; }
::-moz-selection { background-color: #c18d34; }a,a>span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #c18d34; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #c18d34; }.post-format .format-container { border-color: #c18d34; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #c18d34!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #b51212; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #b51212; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #b51212; }
.post-comments::before { border-right-color: #b51212; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #b52515}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #b52515; }
              }#header { background-color: #825f2c; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #825f2c; }
}
        #header #nav-mobile { background-color: #b52515; }#nav-header.nav-container, #main-header-search .search-expand { background-color: #c63d21; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #c63d21; }
}
        .site-title a img { max-height: 150px; }body {background: #cccccc url(https://rpgamer.com/wp-content/uploads/2020/06/background-2020a.png) no-repeat center top;background-attachment:scroll;background-size: contain;}

</style>
<link rel='stylesheet' id='theme-stylesheet-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/style.css?x89916&amp;ver=3.3.28.c1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css'  href='https://rpgamer.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?x89916&amp;ver=3.3.28.c1.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='um_fonticons_ii-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fonticons-ii.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_fonticons_fa-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fonticons-fa.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='select2-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/select2/select2.min.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_crop-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-crop.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_modal-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-modal.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_styles-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-styles.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_profile-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-profile.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_account-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-account.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_misc-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-misc.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_fileupload-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fileupload.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime_date-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.date.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime_time-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.time.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_raty-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-raty.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_scrollbar-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/simplebar.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_tipsy-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-tipsy.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_responsive-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-responsive.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_default_css-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-old-default.css?x89916&amp;ver=2.1.10' type='text/css' media='all' />
<link rel='stylesheet' id='um_old_css-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/../../uploads/ultimatemember/um_old_settings.css?x89916&amp;ver=5.5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/jquery/jquery.js?x89916&amp;ver=1.12.4-wp' id='jquery-core-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-gdpr.min.js?x89916&amp;ver=2.1.10' id='um-gdpr-js'></script>
<link rel="https://api.w.org/" href="https://rpgamer.com/wp-json/" /><link rel="alternate" type="application/json" href="https://rpgamer.com/wp-json/wp/v2/posts/80032" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rpgamer.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rpgamer.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Yo-kai Watch Jam: Yo-kai Academy Y PS4 Version, Switch Update Dated in Japan' href='https://rpgamer.com/2020/09/yo-kai-watch-jam-yo-kai-academy-y-ps4-version-switch-update-dated-in-japan/' />
<link rel='next' title='Citizens Unite! Earth x Space Compilation Coming to PS4 and Switch' href='https://rpgamer.com/2020/09/citizens-unite-earth-x-space-compilation-coming-to-ps4-and-switch/' />
<meta name="generator" content="WordPress 5.5.1" />
<link rel="canonical" href="https://rpgamer.com/2020/09/rpg-cast-episode-557-ps5-crunchwrap-supreme/" />
<link rel='shortlink' href='https://rpgamer.com/?p=80032' />
<link rel="alternate" type="application/json+oembed" href="https://rpgamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frpgamer.com%2F2020%2F09%2Frpg-cast-episode-557-ps5-crunchwrap-supreme%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://rpgamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frpgamer.com%2F2020%2F09%2Frpg-cast-episode-557-ps5-crunchwrap-supreme%2F&#038;format=xml" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
		<style type="text/css">
			.um_request_name {
				display: none !important;
			}
		</style>
	<meta name="copyright" content="Copyright (c)1998-2020 RPGamer. All Rights Reserved.">
<meta name="keywords" content="RPGs, video games, RPGamer, Switch, PS4, Vita, Xbox One, PC,reviews, news, features, editorials">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@RPGamer">
<meta property="og:site_name" content="RPGamer">
<meta name="description" content="This week we finally figure out if Dark Souls ripped off Breath of the Wild. We also get really worked up over Bethesda. When is Game Pass coming to PS5, again?">
<meta property="og:description" content="This week we finally figure out if Dark Souls ripped off Breath of the Wild. We also get really worked up over Bethesda. When is Game Pass coming to PS5, again?">
<meta property="og:image" content="https://rpgamer.com/wp-content/uploads/2017/10/RPGCast.jpg">
<meta property="twitter:image" content="https://rpgamer.com/wp-content/uploads/2017/10/RPGCast.jpg">
<!--[if lt IE 9]>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js?x89916"></script>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js?x89916"></script>
<![endif]-->
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-32x32.png?x89916" sizes="32x32" />
<link rel="icon" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-192x192.png?x89916" sizes="192x192" />
<link rel="apple-touch-icon" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-180x180.png?x89916" />
<meta name="msapplication-TileImage" content="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-270x270.png" />
<style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- IMPORTANT: Place these lines as high as you can in <head>, ideally just after <title> tag -->
<link rel="preconnect" href="https://tags.bkrtx.com/">
<link rel="preconnect" href="https://securepubads.g.doubleclick.net/" crossorigin>
<link rel="preconnect" href="https://cdn.consentmanager.mgr.consensu.org/" crossorigin>

<!-- Place the below code anywhere you like in the <head> (higher is better) -->
<script>window.AdSlots = window.AdSlots || {cmd: [], disableScripts: ['gpt','bk']};</script>
<script async src="https://tags.bkrtx.com/js/bk-coretag.js"></script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src="/dist/rpgamer.min.js?x89916"></script>

<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-69178-8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-69178-8');
</script>
</head>

<body class="post-template-default single single-post postid-80032 single-format-standard wp-embed-responsive col-2cl full-width topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
  <a class="screen-reader-text skip-link" href="#content">Skip to content</a>
  <div class="widget-extra-header-widget"><div class="widget-extra-header-widget-inner"><div class='code-block code-block-1' style='text-align: center; clear: both;'>
<div id="nn_lb1"></div></div>
</div></div>
  <header id="header" class="specific-mobile-menu-on one-mobile-menu mobile_menu header-ads-desktop header-ads-mobile  no-header-img">
        <nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
  <div class="mobile-title-logo-in-header"></div>
        
                    <!-- <div class="ham__navbar-toggler collapsed" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="ham-toggler-menu__span"></span>
          </div>
        </div> -->
        <button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
          <span class="ham__navbar-span-wrapper">
            <span class="line line-1"></span>
            <span class="line line-2"></span>
            <span class="line line-3"></span>
          </span>
        </button>
            
      <div class="nav-text"></div>
      <div class="nav-wrap container">
                  <ul class="nav container-inner group mobile-search">
                            <li>
                  <form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </li>
                      </ul>
                <ul id="menu-topbear" class="nav container-inner group"><li id="menu-item-103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103"><a href="/">Home</a></li>
<li id="menu-item-18160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18160"><a href="/review/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-18089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18089"><a href="/review">Review Archive</a></li>
	<li id="menu-item-18090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18090"><a href="https://rpgamer.com/category/reviews/">Latest Reviews</a></li>
	<li id="menu-item-40189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40189"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li id="menu-item-62274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62274"><a href="https://rpgamer.com/category/deep-looks/">Deep Looks</a></li>
</ul>
</li>
<li id="menu-item-87" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87"><a href="https://rpgamer.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-786"><a href="https://rpgamer.com/category/features/interviews/">Interviews</a></li>
	<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://rpgamer.com/category/impressions/">Impressions</a></li>
	<li id="menu-item-52009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52009"><a href="https://rpgamer.com/category/features/editorials/">Editorials</a></li>
	<li id="menu-item-8195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8195"><a href="https://rpgamer.com/category/features/awards/">Awards</a></li>
	<li id="menu-item-71822" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-71822"><a href="https://rpgamer.com/2020/04/rpgamers-rpgs-of-the-decade-introduction/">RPGs of the Decade</a></li>
	<li id="menu-item-62275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62275"><a href="https://rpgamer.com/category/adventure-corner/">Adventure Corner</a></li>
	<li id="menu-item-8252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8252"><a href="https://rpgamer.com/category/features/special-features/">Special Features</a></li>
</ul>
</li>
<li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88"><a href="https://rpgamer.com/category/news/">News</a></li>
<li id="menu-item-318" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-318"><a href="/discord">Community</a>
<ul class="sub-menu">
	<li id="menu-item-26116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26116"><a href="/discord">Discord</a></li>
	<li id="menu-item-26117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26117"><a href="http://forums.rpgamer.com/">Forums</a></li>
</ul>
</li>
<li id="menu-item-276" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-276"><a href="https://rpgamer.com/category/podcasts/">Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-280" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-280"><a href="https://rpgamer.com/category/podcasts/rpgcast/">RPG Cast</a></li>
	<li id="menu-item-279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279"><a href="https://rpgamer.com/category/podcasts/backtrack/">RPG Backtrack</a></li>
	<li id="menu-item-278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-278"><a href="https://rpgamer.com/category/podcasts/qaquest/">Q&#038;A Quest</a></li>
	<li id="menu-item-277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277"><a href="https://rpgamer.com/category/podcasts/atbs/">Active Topical Banter Show</a></li>
	<li id="menu-item-21054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21054"><a href="https://rpgamer.com/category/podcasts/thehunt/">The Hunt</a></li>
</ul>
</li>
<li id="menu-item-17948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17948"><a href="/platform/">Games</a>
<ul class="sub-menu">
	<li id="menu-item-17953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17953"><a href="/platform/ps5">PlayStation 5</a></li>
	<li id="menu-item-17949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17949"><a href="/platform/ps4">PlayStation 4</a></li>
	<li id="menu-item-76506" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76506"><a href="/platform/xbsx">Xbox Series X</a></li>
	<li id="menu-item-17950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17950"><a href="/platform/xbone">Xbox One</a></li>
	<li id="menu-item-17951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17951"><a href="/platform/nsw">Nintendo Switch</a></li>
	<li id="menu-item-17952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17952"><a href="/platform/win">PC</a></li>
	<li id="menu-item-17963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17963"><a href="https://rpgamer.com/platform/">Other Platforms</a></li>
</ul>
</li>
<li id="menu-item-299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-299"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a>
<ul class="sub-menu">
	<li id="menu-item-303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-303"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a></li>
	<li id="menu-item-301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-301"><a href="https://rpgamer.com/about-rpgamer/current-staff/">Current Staff</a></li>
	<li id="menu-item-300" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300"><a href="https://rpgamer.com/about-rpgamer/indie-submissions/">Indie Submissions</a></li>
	<li id="menu-item-880" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li id="menu-item-879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-879"><a href="https://rpgamer.com/about-rpgamer/volunteer-applications/">Volunteer Applications</a></li>
	<li id="menu-item-30001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30001"><a href="https://rpgamer.com/site-quotes/">Site Quotes</a></li>
	<li id="menu-item-30318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30318"><a href="https://rpgamer.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-18213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18213"><a href="https://rpgamer.com/login/">Login</a>
<ul class="sub-menu">
	<li id="menu-item-21988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21988"><a href="https://rpgamer.com/register/">Register</a></li>
</ul>
</li>
</ul>      </div>
</nav><!--/#nav-topbar-->  
        <nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
    <div class="nav-text"></div>
  <div class="topbar-toggle-down">
    <i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
    <i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
  </div>
  <div class="nav-wrap container">
    <ul id="menu-topbear-1" class="nav container-inner group"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18160"><a href="/review/">Reviews</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18089"><a href="/review">Review Archive</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18090"><a href="https://rpgamer.com/category/reviews/">Latest Reviews</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40189"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62274"><a href="https://rpgamer.com/category/deep-looks/">Deep Looks</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87"><a href="https://rpgamer.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-786"><a href="https://rpgamer.com/category/features/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://rpgamer.com/category/impressions/">Impressions</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52009"><a href="https://rpgamer.com/category/features/editorials/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8195"><a href="https://rpgamer.com/category/features/awards/">Awards</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-post menu-item-71822"><a href="https://rpgamer.com/2020/04/rpgamers-rpgs-of-the-decade-introduction/">RPGs of the Decade</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62275"><a href="https://rpgamer.com/category/adventure-corner/">Adventure Corner</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8252"><a href="https://rpgamer.com/category/features/special-features/">Special Features</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88"><a href="https://rpgamer.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-318"><a href="/discord">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26116"><a href="/discord">Discord</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26117"><a href="http://forums.rpgamer.com/">Forums</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-276"><a href="https://rpgamer.com/category/podcasts/">Podcasts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-280"><a href="https://rpgamer.com/category/podcasts/rpgcast/">RPG Cast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279"><a href="https://rpgamer.com/category/podcasts/backtrack/">RPG Backtrack</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-278"><a href="https://rpgamer.com/category/podcasts/qaquest/">Q&#038;A Quest</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277"><a href="https://rpgamer.com/category/podcasts/atbs/">Active Topical Banter Show</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21054"><a href="https://rpgamer.com/category/podcasts/thehunt/">The Hunt</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17948"><a href="/platform/">Games</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17953"><a href="/platform/ps5">PlayStation 5</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17949"><a href="/platform/ps4">PlayStation 4</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-76506"><a href="/platform/xbsx">Xbox Series X</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17950"><a href="/platform/xbone">Xbox One</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17951"><a href="/platform/nsw">Nintendo Switch</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17952"><a href="/platform/win">PC</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17963"><a href="https://rpgamer.com/platform/">Other Platforms</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-299"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-303"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-301"><a href="https://rpgamer.com/about-rpgamer/current-staff/">Current Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300"><a href="https://rpgamer.com/about-rpgamer/indie-submissions/">Indie Submissions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-879"><a href="https://rpgamer.com/about-rpgamer/volunteer-applications/">Volunteer Applications</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30001"><a href="https://rpgamer.com/site-quotes/">Site Quotes</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30318"><a href="https://rpgamer.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18213"><a href="https://rpgamer.com/login/">Login</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21988"><a href="https://rpgamer.com/register/">Register</a></li>
</ul>
</li>
</ul>  </div>
      <div id="topbar-header-search" class="container">
      <div class="container-inner">
        <button class="toggle-search"><i class="fas fa-search"></i></button>
        <div class="search-expand">
          <div class="search-expand-inner"><form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div>
        </div>
      </div><!--/.container-inner-->
    </div><!--/.container-->
  
</nav><!--/#nav-topbar-->  
  <div class="container group">
        <div class="container-inner">

                    <div class="group hu-pad central-header-zone">
                  <div class="logo-tagline-group">
                                                              </div>

                                </div>
      
      
    </div><!--/.container-inner-->
      </div><!--/.container-->

</header><!--/#header-->
  
  <div class="container" id="page">
    <div class="container-inner">
            <div class="main">
        <div class="main-inner group">
          
              <section class="content">
              <div class="page-title hu-pad group">
          	    		<ul class="meta-single group">
    			<li class="category"><a href="https://rpgamer.com/category/news/" rel="category tag">News</a> <span>/</span> <a href="https://rpgamer.com/category/podcasts/" rel="category tag">Podcasts</a> <span>/</span> <a href="https://rpgamer.com/category/podcasts/rpgcast/" rel="category tag">RPG Cast</a></li>
    			    		</ul>

    	
    </div><!--/.page-title-->
          <div class="hu-pad group">
              <article class="post-80032 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-podcasts category-rpgcast tag-13-sentinels-aegis-rim tag-dragons-dogma-dark-arisen tag-hades tag-world-of-warcraft-battle-for-azeroth">
    <div class="post-inner group">

      <h1 class="post-title entry-title">RPG Cast &#8211; Episode 557: &#8220;PS5 Crunchwrap Supreme!&#8221;</h1>
  <p class="post-byline">
       by     <span class="vcard author">
       <span class="fn"><a href="https://rpgamer.com/author/sabin/" title="Posts by Chris Privitere" rel="author">Chris Privitere</a></span>
     </span>
     &middot;
                            
                                Published <time class="published" datetime="2020-09-26T12:47:55-07:00">September 26, 2020</time>
                &middot; Updated <time class="updated" datetime="2020-09-26T12:48:23-07:00">September 26, 2020</time>
                      </p>

                                
      <div class="clear"></div>

      <div class="entry themeform">
        <div class="entry-inner">
          <p>This week we finally figure out if Dark Souls ripped off Breath of the Wild. We also get really worked up over Bethesda. When is Game Pass coming to PS5, again?</p>
<p><strong>Question of the Week</strong><br />
What game could you play over and over again and not get bored?</p>
<p><a href="https://docs.google.com/spreadsheets/d/1hLXOun1ZxUP6E_vRgsLTdrSzy7q-h4iCHJt3EDYuKRs/edit?usp=sharing" rel="noopener noreferrer" target="_blank">Check out the show notes here!</a></p>
<div class="powerpress_player" id="powerpress_player_637"><!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-80032-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast557.mp3?_=1" /><a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast557.mp3">https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast557.mp3</a></audio></div><p class="powerpress_links powerpress_links_mp3">Podcast: <a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast557.mp3" class="powerpress_link_pinw" target="_blank" title="Play in new window" onclick="return powerpress_pinw('https://rpgamer.com/?powerpress_pinw=80032-podcast');" rel="nofollow">Play in new window</a> | <a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast557.mp3" class="powerpress_link_d" title="Download" rel="nofollow" download="rpgcast557.mp3">Download</a></p><p class="powerpress_links powerpress_subscribe_links">Subscribe: <a href="https://podcasts.apple.com/podcast/rpg-cast/id264306390?mt=2&amp;ls=1" class="powerpress_link_subscribe powerpress_link_subscribe_itunes" title="Subscribe on Apple Podcasts" rel="nofollow">Apple Podcasts</a> | <a href="http://subscribeonandroid.com/feeds.feedburner.com/Rpgcast" class="powerpress_link_subscribe powerpress_link_subscribe_android" title="Subscribe on Android" rel="nofollow">Android</a> | <a href="https://www.google.com/podcasts?feed=aHR0cDovL2ZlZWRzLmZlZWRidXJuZXIuY29tL1JwZ2Nhc3Q" class="powerpress_link_subscribe powerpress_link_subscribe_googleplay" title="Subscribe on Google Podcasts" rel="nofollow">Google Podcasts</a> | <a href="https://www.stitcher.com/podcast/rpg-cast" class="powerpress_link_subscribe powerpress_link_subscribe_stitcher" title="Subscribe on Stitcher" rel="nofollow">Stitcher</a> | <a href="http://feeds.feedburner.com/Rpgcast" class="powerpress_link_subscribe powerpress_link_subscribe_rss" title="Subscribe via RSS" rel="nofollow">RSS</a></p><input class="fooboxshare_post_id" type="hidden" value="80032"/>          <nav class="pagination group">
                      </nav><!--/.pagination-->
        </div>

        
        <div class="clear"></div>
      </div><!--/.entry-->

    </div><!--/.post-inner-->
  </article><!--/.post-->

<div class="clear"></div>

<p class="post-tags"><span>Tags:</span> <a href="https://rpgamer.com/tag/13-sentinels-aegis-rim/" rel="tag">13 Sentinels: Aegis Rim</a><a href="https://rpgamer.com/tag/dragons-dogma-dark-arisen/" rel="tag">Dragon's Dogma: Dark Arisen</a><a href="https://rpgamer.com/tag/hades/" rel="tag">Hades</a><a href="https://rpgamer.com/tag/world-of-warcraft-battle-for-azeroth/" rel="tag">World of Warcraft: Battle for Azeroth</a></p>



<h4 class="heading">
	<i class="far fa-hand-point-right"></i>You may also like...</h4>

<ul class="related-posts group">
  		<li class="related post-hover">
		<article class="post-40706 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-13-sentinels-aegis-rim tag-atlus tag-ps4 tag-vanillaware">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2019/01/13-sentinels-aegis-rim-prologue-gets-a-trailer/" class="hu-rel-post-thumb">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2019/01/13-sentinels_2019-01-08_005-520x200.jpg?x89916"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" loading="lazy" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2019/01/13-sentinels-aegis-rim-prologue-gets-a-trailer/" rel="bookmark" title="Permalink to 13 Sentinels: Aegis Rim Prologue Gets a Trailer">13 Sentinels: Aegis Rim Prologue Gets a Trailer</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2019-01-15 04:32:45">January 15, 2019</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/scion/" title="Posts by Zack Webster" rel="author">Zack Webster</a></span>
    </span> &middot; Published <span class="published">January 15, 2019</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-40311 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-capcom tag-dragons-dogma tag-dragons-dogma-dark-arisen tag-switch">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2019/01/dragons-dogma-dark-arisen-coming-to-switch-in-april/" class="hu-rel-post-thumb">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2019/01/dragons-dogma-dark-arisen_2019-01-08_004-520x200.jpg?x89916"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" loading="lazy" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2019/01/dragons-dogma-dark-arisen-coming-to-switch-in-april/" rel="bookmark" title="Permalink to Dragon&#8217;s Dogma: Dark Arisen Coming to Switch in April">Dragon&#8217;s Dogma: Dark Arisen Coming to Switch in April</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2019-01-08 13:19:59">January 8, 2019</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/severinmira/" title="Posts by Alex Fuller" rel="author">Alex Fuller</a></span>
    </span> &middot; Published <span class="published">January 8, 2019</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-79802 post type-post status-publish format-standard has-post-thumbnail hentry category-featured-content category-reviews tag-13-sentinels-aegis-rim tag-atlus tag-ps4 tag-vanillaware">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2020/09/13-sentinels-aegis-rim-video-review/" class="hu-rel-post-thumb">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2020/08/13-sentinels-aegis-rim_2020-08-20_048-520x200.jpg?x89916"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" loading="lazy" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2020/09/13-sentinels-aegis-rim-video-review/" rel="bookmark" title="Permalink to 13 Sentinels: Aegis Rim Video Review">13 Sentinels: Aegis Rim Video Review</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2020-09-21 10:01:14">September 21, 2020</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/severinmira/" title="Posts by Alex Fuller" rel="author">Alex Fuller</a></span>
    </span> &middot; Published <span class="published">September 21, 2020</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		  
</ul><!--/.post-related-->



<section id="comments" class="themeform">

	
		<h3 class="heading">1 Response</h3>

		<ul class="comment-tabs group">
			<li class="active"><a href="#commentlist-container"><i class="far fa-comments"></i>Comments<span>1</span></a></li>
			<li><a href="#pinglist-container"><i class="fas fa-share"></i>Pingbacks<span>0</span></a></li>
		</ul>

				<div id="commentlist-container" class="comment-tab">

			<ol class="commentlist">
						<li class="comment byuser comment-author-plattym3 even thread-even depth-1" id="comment-2419">
				<div id="div-comment-2419" class="comment-body">
				<div class="comment-author vcard">
			<img src="https://rpgamer.com/wp-content/uploads/ultimatemember/158/profile_photo-80.png?x89916&amp;1601160686" class="gravatar avatar avatar-48 um-avatar um-avatar-uploaded" width="48" height="48" alt="plattym3" data-default="https://rpgamer.com/wp-content/plugins/ultimate-member/assets/img/default_avatar.jpg" onerror="if ( ! this.getAttribute('data-load-error') ){ this.setAttribute('data-load-error', '1');this.setAttribute('src', this.getAttribute('data-default'));}" />			<cite class="fn"><a href="https://rpgamer.com/user/plattym3/">plattym3</a></cite> <span class="says">says:</span>		</div>
		
		<div class="comment-meta commentmetadata"><a href="https://rpgamer.com/2020/09/rpg-cast-episode-557-ps5-crunchwrap-supreme/#comment-2419">
			September 26, 2020 at 5:25 pm PDT				</a>
						</div>

		<p>Dragon Quest Monsters 2 would be my forever game. Between hundreds of DQ monsters to breed, and some of those breeding chains being tons of generations deep, there&#8217;s always another monster to make and another party combination to try. The key system which allows for mixing and matching of a near infinite amount of procedurally generated worlds to explore also is something that would keep the game always fresh each playthrough.</p>

		<div class="reply"><a rel="nofollow" class="comment-reply-login" href="https://rpgamer.com/login/?redirect_to=https%3A%2F%2Frpgamer.com%2F2020%2F09%2Frpg-cast-episode-557-ps5-crunchwrap-supreme%2F">Log in to Reply</a></div>
				</div>
				</li><!-- #comment-## -->
			</ol><!--/.commentlist-->

			
		</div>
		
		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/rpg-cast-episode-557-ps5-crunchwrap-supreme/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+Rpgcast+%28RPG+Cast%29#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://rpgamer.com/login/?redirect_to=https%3A%2F%2Frpgamer.com%2F2020%2F09%2Frpg-cast-episode-557-ps5-crunchwrap-supreme%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</section><!--/#comments-->          </div><!--/.pad-->
			        </section><!--/.content-->
          

	<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">

		<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas sidebar-toggle-arrows"></i></button>

		<div class="sidebar-content">

			           			<div class="sidebar-top group">
                        <p>Follow:</p>                    <ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/RPGamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/RPGamer/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Youtube" aria-label="Follow us on Youtube" href="https://www.youtube.com/user/RPGamerdotcom" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-youtube"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitch" aria-label="Follow us on Twitch" href="https://www.twitch.tv/rpgamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitch"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Discord" aria-label="Follow us on Discord" href="https://discord.gg/QEsbnvx" target="_blank" ><i class="fab fa-discord"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="/feed/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul>  			</div>
			
				<ul class="post-nav group">
		<li class="next"><a href="https://rpgamer.com/2020/09/citizens-unite-earth-x-space-compilation-coming-to-ps4-and-switch/" rel="next"><i class="fas fa-chevron-right"></i><strong>Next story</strong> <span>Citizens Unite! Earth x Space Compilation Coming to PS4 and Switch</span></a></li>
		<li class="previous"><a href="https://rpgamer.com/2020/09/yo-kai-watch-jam-yo-kai-academy-y-ps4-version-switch-update-dated-in-japan/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>Yo-kai Watch Jam: Yo-kai Academy Y PS4 Version, Switch Update Dated in Japan</span></a></li>
	</ul>

			
			<div id="text-3" class="widget widget_text">			<div class="textwidget"><p>RPGamer has been covering RPGs since 1998, with the current version of the site launched in 2018. Due to the wholesale change in our back-end and systems only certain content created from 2018 onwards has been carried over to our new site. However, all of our older content can still be found at <a href="http://archive.rpgamer.com">archive.rpgamer.com</a>.</p>
</div>
		</div><div id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="ai_widget-6" class="widget ai_widget"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_mpu1"></div></div>
</div><div id="alxposts-7" class="widget widget_hu_posts">
<h3 class="widget-title">Featured Posts</h3>
	
	<ul class="alx-posts group ">
    				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/final-fantasy-crystal-chronicles-remastered-edition-review/" rel="bookmark" title="Permalink to Final Fantasy Crystal Chronicles Remastered Edition Review">Final Fantasy Crystal Chronicles Remastered Edition Review</a></p>
				<p class="post-item-date">22 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/moero-crystal-h-review/" rel="bookmark" title="Permalink to Moero Crystal H Review">Moero Crystal H Review</a></p>
				<p class="post-item-date">21 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/13-sentinels-aegis-rim-video-review/" rel="bookmark" title="Permalink to 13 Sentinels: Aegis Rim Video Review">13 Sentinels: Aegis Rim Video Review</a></p>
				<p class="post-item-date">21 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/mortal-shell-review/" rel="bookmark" title="Permalink to Mortal Shell Review">Mortal Shell Review</a></p>
				<p class="post-item-date">17 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/why-did-ya-date-me-the-legend-of-heroes-trails-of-cold-steel-edition/" rel="bookmark" title="Permalink to Why Did Ya Date Me? The Legend of Heroes: Trails of Cold Steel Edition">Why Did Ya Date Me? The Legend of Heroes: Trails of Cold Steel Edition</a></p>
				<p class="post-item-date">17 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/13-sentinels-aegis-rim-review/" rel="bookmark" title="Permalink to 13 Sentinels: Aegis Rim Review">13 Sentinels: Aegis Rim Review</a></p>
				<p class="post-item-date">15 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/rpg-elements-final-fantasy-xv-the-dawn-of-the-future/" rel="bookmark" title="Permalink to RPG Elements: Final Fantasy XV: The Dawn of the Future">RPG Elements: Final Fantasy XV: The Dawn of the Future</a></p>
				<p class="post-item-date">15 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/composer-noriyuki-iwadare-interview/" rel="bookmark" title="Permalink to Composer Noriyuki Iwadare Interview">Composer Noriyuki Iwadare Interview</a></p>
				<p class="post-item-date">14 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/the-outer-worlds-peril-on-gorgon-dlc-deep-look/" rel="bookmark" title="Permalink to The Outer Worlds: Peril on Gorgon DLC Deep Look">The Outer Worlds: Peril on Gorgon DLC Deep Look</a></p>
				<p class="post-item-date">14 Sep, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/09/dragon-age-inquisition-provides-a-game-changing-model-for-world-saving-adventure/" rel="bookmark" title="Permalink to Dragon Age: Inquisition Provides a Game-Changing Model for World-Saving Adventure">Dragon Age: Inquisition Provides a Game-Changing Model for World-Saving Adventure</a></p>
				<p class="post-item-date">13 Sep, 2020</p>			</div>

		</li>
				    	</ul><!--/.alx-posts-->

</div>
<div id="released_widget-4" class="widget widget_released_widget"><h3 class="widget-title">Recent Releases</h3><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.24</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/tears-of-avia/'>Tears of Avia</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.24</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/against-the-moon/'>Against the Moon</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.22</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/rebel-galaxy-outlaw/'>Rebel Galaxy Outlaw</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.22</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/13-sentinels-aegis-rim/'>13 Sentinels: Aegis Rim</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ps4-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.18</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/path-of-exile/'>Path of Exile</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/mac-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/vampires-fall-origins/'>Vampire's Fall: Origins</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/moero-crystal-h/'>Moero Crystal H</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/the-dungeon-of-naheulbeuk-the-amulet-of-chaos/'>The Dungeon of Naheulbeuk: The Amulet of Chaos</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/hades/'>Hades</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/harvest-moon-light-of-hope/'>Harvest Moon: Light of Hope</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/xbone.gif?x89916"></div></div></div><div id="upcoming_widget-4" class="widget widget_upcoming_widget"><h3 class="widget-title">Upcoming Releases</h3><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.28</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/undead-darlings-no-cure-for-love/'>Undead Darlings: No Cure for Love</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.28</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/genshin-impact/'>Genshin Impact</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>09.29</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/warsaw/'>Warsaw</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ps4-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.01</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/ys-origin/'>Ys Origin</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.01</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/warsaw/'>Warsaw</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.01</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/orangeblood/'>Orangeblood</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.02</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/warsaw/'>Warsaw</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/xbone.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.08</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/ikenfell/'>Ikenfell</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.13</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/woodsalt/'>Woodsalt</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>10.15</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/cloudpunk/'>Cloudpunk</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x89916"></div></div></div><div id="custom_html-27" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align:center;"><a href="/platform/">See All Releases</a></div></div></div><div id="custom_html-33" class="widget_text widget widget_custom_html"><h3 class="widget-title">Reader Poll</h3><div class="textwidget custom-html-widget"><script type="text/javascript" charset="utf-8" src="https://secure.polldaddy.com/p/10609155.js"></script>
<noscript><a href="https://poll.fm/10609155">"NVidia just announced the new RTX card.  How is this going to affect you?</a></noscript></div></div><div id="custom_html-39" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align: center;">

		<a href="http://rpgamer.com/discord/" target="_blank" rel="noopener noreferrer">Join the dicussion on Discord.</a></div>
	</div></div><div id="recent-comments-2" class="widget widget_recent_comments"><h3 class="widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/shaymin/">Shaymin</a></span> on <a href="https://rpgamer.com/2020/09/episode-178-ps5-pre-order-bonanza-qa-quest/#comment-2420">Episode 178: PS5 Pre-Order Bonanza &#8211; Q&#038;A Quest</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/plattym3/">plattym3</a></span> on <a href="https://rpgamer.com/2020/09/rpg-cast-episode-557-ps5-crunchwrap-supreme/#comment-2419">RPG Cast &#8211; Episode 557: &#8220;PS5 Crunchwrap Supreme!&#8221;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/traceriii/">Traceriii</a></span> on <a href="https://rpgamer.com/2020/09/rpg-cast-episode-556-chris-is-right-for-once/#comment-2418">RPG Cast &#8211; Episode 556: &#8220;Chris Is Right for Once!&#8221;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/strawberryeggs/">StrawberryEggs</a></span> on <a href="https://rpgamer.com/2020/09/rpg-cast-episode-556-chris-is-right-for-once/#comment-2417">RPG Cast &#8211; Episode 556: &#8220;Chris Is Right for Once!&#8221;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/ultrakev9/">UltraKev9</a></span> on <a href="https://rpgamer.com/review/moero-crystal-h-review/#comment-2415">Moero Crystal H Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/featherhoof/">FeatherHoof</a></span> on <a href="https://rpgamer.com/2020/09/rpg-cast-episode-556-chris-is-right-for-once/#comment-2414">RPG Cast &#8211; Episode 556: &#8220;Chris Is Right for Once!&#8221;</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/pawsrpg/">pawsrpg</a></span> on <a href="https://rpgamer.com/review/moero-crystal-h-review/#comment-2413">Moero Crystal H Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/ultrakev9/">UltraKev9</a></span> on <a href="https://rpgamer.com/review/moero-crystal-h-review/#comment-2412">Moero Crystal H Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/ultrakev9/">UltraKev9</a></span> on <a href="https://rpgamer.com/review/moero-crystal-h-review/#comment-2411">Moero Crystal H Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/shaymin/">Shaymin</a></span> on <a href="https://rpgamer.com/2020/09/rpg-cast-episode-556-chris-is-right-for-once/#comment-2410">RPG Cast &#8211; Episode 556: &#8220;Chris Is Right for Once!&#8221;</a></li></ul></div>
		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	

        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
  <div class="widget-extra-footer-widget"><div class="widget-extra-footer-widget-inner"><div class='code-block code-block-2' style='text-align: center; clear: both;'>
<div id="nn_lb2"></div></div>
</div></div>  <footer id="footer">

    
    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fas fa-angle-up"></i></a>

        <div class="hu-pad group">

          <div class="grid one-half">
                        
            <div id="copyright">
                <p>© 2020 RPGamer - <a class="nn-cmp-show" href="#">Manage Cookie Settings</a></p>
            </div><!--/#copyright-->

            
          </div>

          <div class="grid one-half last">
                                          <ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/RPGamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/RPGamer/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Youtube" aria-label="Follow us on Youtube" href="https://www.youtube.com/user/RPGamerdotcom" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-youtube"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitch" aria-label="Follow us on Twitch" href="https://www.twitch.tv/rpgamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitch"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Discord" aria-label="Follow us on Discord" href="https://discord.gg/QEsbnvx" target="_blank" ><i class="fab fa-discord"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="/feed/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul>                                    </div>

        </div><!--/.hu-pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<div class='ai-viewports ai-viewport-1 ai-insert-4-27178153' data-insertion='after' data-selector='.ai-insert-4-27178153' data-insertion-no-dbg data-code='PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTQnIHN0eWxlPScnPgo8ZGl2IGlkPSJubl9za2lubCI+PC9kaXY+PC9kaXY+Cg==' data-block='4'></div>

<div class='ai-viewports ai-viewport-1 ai-insert-5-13943418' data-insertion='after' data-selector='.ai-insert-5-13943418' data-insertion-no-dbg data-code='PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTUnIHN0eWxlPScnPgo8ZGl2IGlkPSJubl9za2luciI+PC9kaXY+PC9kaXY+Cg==' data-block='5'></div>


<div id="um_upload_single" style="display:none"></div>
<div id="um_view_photo" style="display:none">

	<a href="javascript:void(0);" data-action="um_remove_modal" class="um-modal-close"
	   aria-label="Close view photo modal">
		<i class="um-faicon-times"></i>
	</a>

	<div class="um-modal-body photo">
		<div class="um-modal-photo"></div>
	</div>

</div><link rel='stylesheet' id='mediaelement-css'  href='https://rpgamer.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?x89916&amp;ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://rpgamer.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?x89916&amp;ver=5.5.1' type='text/css' media='all' />
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/underscore.min.js?x89916&amp;ver=1.8.3' id='underscore-js'></script>
<script type='text/javascript' id='hu-front-scripts-js-extra'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":false,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100,"threshold":0}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":true},"sidebarOneWidth":"340","sidebarTwoWidth":"260","isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_always","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/rpgamer.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"98a1b917e8"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"},"deferFontAwesome":"","fontAwesomeUrl":"https:\/\/rpgamer.com\/wp-content\/themes\/hueman\/assets\/front\/css\/font-awesome.min.css?3.3.28.c1.9.6","mainScriptUrl":"https:\/\/rpgamer.com\/wp-content\/themes\/hueman\/assets\/front\/js\/scripts.min.js?3.3.28.c1.9.6","flexSliderNeeded":"","flexSliderOptions":{"is_rtl":false,"has_touch_support":true,"is_slideshow":true,"slideshow_speed":7000}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?x89916&amp;ver=3.3.28.c1.9.6' id='hu-front-scripts-js' defer></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/comment-reply.min.js?x89916&amp;ver=5.5.1' id='comment-reply-js'></script>
<script type='text/javascript' id='foobox-debug-js-before'>
/* Run FooBox (v2.7.11) */
var FOOBOX = window.FOOBOX = {
	ready: true,
	preloadFont: true,
	disableOthers: false,
	customOptions: {  },
	o: {wordpress: { enabled: true },
		pan: { enabled: true, showOverview: true, position: "fbx-top-right" },
		debug:true,
		deeplinking : { enabled: true, prefix: "foobox" },
		fullscreen : { enabled: true, useAPI: true },
		effect: 'fbx-effect-1',
		excludes:'.fbx-link,.nofoobox,.nolightbox,a[href*="pinterest.com/pin/create/button/"]',
		affiliate : { enabled: false },
		slideshow: { enabled:true},
		social: {"enabled":true,"position":"fbx-above","mailto":true,"download":true,"excludes":[],"nonce":"e7808876c4","networks":["facebook","twitter","pinterest","tumblr","reddit"]},
		preload:true},
	selectors: [
		".gallery", ".wp-block-gallery", ".foogallery-container.foogallery-lightbox-foobox", ".foogallery-container.foogallery-lightbox-foobox-free", ".foobox, [target=\"foobox\"]", ".wp-caption", ".wp-block-image", "a:has(img[class*=wp-image-])"
	],
	pre: function( $ ){
		// Custom JavaScript (Pre)
		
	},
	post: function( $ ){
		// Custom JavaScript (Post)
		
		// Custom Captions Code
		
	},
	custom: function( $ ){
		// Custom Extra JS
		
	}
};
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/foobox-image-lightbox-premium/pro/js/foobox.debug.js?x89916&amp;ver=2.7.11' id='foobox-debug-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/select2/select2.full.min.js?x89916&amp;ver=2.1.10' id='select2-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/wp-util.min.js?x89916&amp;ver=5.5.1' id='wp-util-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-crop.min.js?x89916&amp;ver=2.1.10' id='um_crop-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-modal.min.js?x89916&amp;ver=2.1.10' id='um_modal-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-jquery-form.min.js?x89916&amp;ver=2.1.10' id='um_jquery_form-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-fileupload.min.js?x89916&amp;ver=2.1.10' id='um_fileupload-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.js?x89916&amp;ver=2.1.10' id='um_datetime-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.date.js?x89916&amp;ver=2.1.10' id='um_datetime_date-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.time.js?x89916&amp;ver=2.1.10' id='um_datetime_time-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?x89916&amp;ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?x89916&amp;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?x89916&amp;ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?x89916&amp;ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?x89916&amp;ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?x89916&amp;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?x89916&amp;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/dist/i18n.min.js?x89916&amp;ver=bb7c3c45d012206bfcd73d6a31f84d9e' id='wp-i18n-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-raty.min.js?x89916&amp;ver=2.1.10' id='um_raty-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-tipsy.min.js?x89916&amp;ver=2.1.10' id='um_tipsy-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/imagesloaded.min.js?x89916&amp;ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/masonry.min.js?x89916&amp;ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/jquery/jquery.masonry.min.js?x89916&amp;ver=3.1.2b' id='jquery-masonry-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/simplebar.min.js?x89916&amp;ver=2.1.10' id='um_scrollbar-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-functions.min.js?x89916&amp;ver=2.1.10' id='um_functions-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-responsive.min.js?x89916&amp;ver=2.1.10' id='um_responsive-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/dist/hooks.min.js?x89916&amp;ver=b4778690e29d8a2b7518413652ba30c4' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-conditional.min.js?x89916&amp;ver=2.1.10' id='um_conditional-js'></script>
<script type='text/javascript' id='um_scripts-js-extra'>
/* <![CDATA[ */
var um_scripts = {"nonce":"03139f1152"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-scripts.min.js?x89916&amp;ver=2.1.10' id='um_scripts-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-profile.min.js?x89916&amp;ver=2.1.10' id='um_profile-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-account.min.js?x89916&amp;ver=2.1.10' id='um_account-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/wp-embed.min.js?x89916&amp;ver=5.5.1' id='wp-embed-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/powerpress/player.min.js?x89916&amp;ver=5.5.1' id='powerpress-player-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?x89916&amp;ver=4.2.13-9993131' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?x89916&amp;ver=5.5.1' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?x89916&amp;ver=5.5.1' id='wp-mediaelement-js'></script>
<style type="text/css">

</style><!--[if lt IE 9]>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/respond.js?x89916"></script>
<![endif]-->
<script>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</script>
		<script type="text/javascript">
			jQuery( window ).on( 'load', function() {
				jQuery('input[name="um_request"]').val('');
			});
		</script>
	</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 354/479 objects using memcached
Page Caching using memcached (Requested URI contains query) 
Database Caching 39/71 queries in 0.024 seconds using memcached

Served from: rpgamer.com @ 2020-09-26 22:51:26 by W3 Total Cache
-->