<!DOCTYPE html>
<html class="no-js" lang="en-US">
<head>
  <meta charset="UTF-8">
  <meta name="viewport" content="width=device-width, initial-scale=1.0">
  <link rel="profile" href="https://gmpg.org/xfn/11" />
  <link rel="pingback" href="https://rpgamer.com/xmlrpc.php">

  <title>RPG Cast &#8211; Episode 534: &#8220;Dr. Thunder Fallout&#8221; &#8211; RPGamer</title>
<script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script>
<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/rpgamer.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://rpgamer.com/wp-includes/css/dist/block-library/style.min.css?x21354&amp;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='foobox-noie7-min-css'  href='https://rpgamer.com/wp-content/plugins/foobox-image-lightbox-premium/pro/css/foobox.noie7.min.css?x21354&amp;ver=2.7.8' type='text/css' media='all' />
<link rel='stylesheet' id='sidebar_releases.css-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/template_css/sidebar_releases.css?x21354&amp;ver=3.3.28.c1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='poll.css-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/template_css/poll.css?x21354&amp;ver=3.3.28.c1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-main-style-css'  href='https://rpgamer.com/wp-content/themes/hueman/assets/front/css/main.min.css?x21354&amp;ver=3.3.28.c1.8.0' type='text/css' media='all' />
<style id='hueman-main-style-inline-css' type='text/css'>
body { font-family:Verdana, sans-serif;font-size:0.75rem }@media only screen and (min-width: 720px) {
        .nav > li { font-size:0.75rem; }
      }.container-inner { max-width: 1120px; }.sidebar .widget { padding-left: 20px; padding-right: 20px; padding-top: 20px; }::selection { background-color: #c18d34; }
::-moz-selection { background-color: #c18d34; }a,a+span.hu-external::after,.themeform label .required,#flexslider-featured .flex-direction-nav .flex-next:hover,#flexslider-featured .flex-direction-nav .flex-prev:hover,.post-hover:hover .post-title a,.post-title a:hover,.sidebar.s1 .post-nav li a:hover i,.content .post-nav li a:hover i,.post-related a:hover,.sidebar.s1 .widget_rss ul li a,#footer .widget_rss ul li a,.sidebar.s1 .widget_calendar a,#footer .widget_calendar a,.sidebar.s1 .alx-tab .tab-item-category a,.sidebar.s1 .alx-posts .post-item-category a,.sidebar.s1 .alx-tab li:hover .tab-item-title a,.sidebar.s1 .alx-tab li:hover .tab-item-comment a,.sidebar.s1 .alx-posts li:hover .post-item-title a,#footer .alx-tab .tab-item-category a,#footer .alx-posts .post-item-category a,#footer .alx-tab li:hover .tab-item-title a,#footer .alx-tab li:hover .tab-item-comment a,#footer .alx-posts li:hover .post-item-title a,.comment-tabs li.active a,.comment-awaiting-moderation,.child-menu a:hover,.child-menu .current_page_item > a,.wp-pagenavi a{ color: #c18d34; }input[type="submit"],.themeform button[type="submit"],.sidebar.s1 .sidebar-top,.sidebar.s1 .sidebar-toggle,#flexslider-featured .flex-control-nav li a.flex-active,.post-tags a:hover,.sidebar.s1 .widget_calendar caption,#footer .widget_calendar caption,.author-bio .bio-avatar:after,.commentlist li.bypostauthor > .comment-body:after,.commentlist li.comment-author-admin > .comment-body:after{ background-color: #c18d34; }.post-format .format-container { border-color: #c18d34; }.sidebar.s1 .alx-tabs-nav li.active a,#footer .alx-tabs-nav li.active a,.comment-tabs li.active a,.wp-pagenavi a:hover,.wp-pagenavi a:active,.wp-pagenavi span.current{ border-bottom-color: #c18d34!important; }.sidebar.s2 .post-nav li a:hover i,
.sidebar.s2 .widget_rss ul li a,
.sidebar.s2 .widget_calendar a,
.sidebar.s2 .alx-tab .tab-item-category a,
.sidebar.s2 .alx-posts .post-item-category a,
.sidebar.s2 .alx-tab li:hover .tab-item-title a,
.sidebar.s2 .alx-tab li:hover .tab-item-comment a,
.sidebar.s2 .alx-posts li:hover .post-item-title a { color: #b51212; }
.sidebar.s2 .sidebar-top,.sidebar.s2 .sidebar-toggle,.post-comments,.jp-play-bar,.jp-volume-bar-value,.sidebar.s2 .widget_calendar caption{ background-color: #b51212; }.sidebar.s2 .alx-tabs-nav li.active a { border-bottom-color: #b51212; }
.post-comments::before { border-right-color: #b51212; }
      .search-expand,
              #nav-topbar.nav-container { background-color: #b52515}@media only screen and (min-width: 720px) {
                #nav-topbar .nav ul { background-color: #b52515; }
              }#header { background-color: #825f2c; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #825f2c; }
}
        #header #nav-mobile { background-color: #b52515; }#nav-header.nav-container, #main-header-search .search-expand { background-color: #c63d21; }
@media only screen and (min-width: 720px) {
  #nav-header .nav ul { background-color: #c63d21; }
}
        .site-title a img { max-height: 150px; }body {background: #848484 url(https://rpgamer.com/wp-content/uploads/2018/08/site-background-new.jpg) repeat-x center top;background-attachment:scroll;}

</style>
<link rel='stylesheet' id='theme-stylesheet-css'  href='https://rpgamer.com/wp-content/themes/hueman-rpgamer-child/style.css?x21354&amp;ver=3.3.28.c1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='hueman-font-awesome-css'  href='https://rpgamer.com/wp-content/themes/hueman/assets/front/css/font-awesome.min.css?x21354&amp;ver=3.3.28.c1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='um_fonticons_ii-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fonticons-ii.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_fonticons_fa-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fonticons-fa.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='select2-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/select2/select2.min.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_crop-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-crop.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_modal-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-modal.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_styles-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-styles.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_profile-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-profile.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_account-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-account.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_misc-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-misc.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_fileupload-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-fileupload.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime_date-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.date.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_datetime_time-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/pickadate/default.time.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_raty-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-raty.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_scrollbar-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/simplebar.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_tipsy-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-tipsy.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_responsive-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-responsive.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_default_css-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/css/um-old-default.css?x21354&amp;ver=2.1.4' type='text/css' media='all' />
<link rel='stylesheet' id='um_old_css-css'  href='https://rpgamer.com/wp-content/plugins/ultimate-member/../../uploads/ultimatemember/um_old_settings.css?x21354&amp;ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/jquery/jquery.js?x21354&amp;ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/jquery/jquery-migrate.min.js?x21354&amp;ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ai_front = {"wp_ai":"5.3.2+2.6.5","insertion_before":"BEFORE","insertion_after":"AFTER","insertion_prepend":"PREPEND CONTENT","insertion_append":"APPEND CONTENT","insertion_replace_content":"REPLACE CONTENT","insertion_replace_element":"REPLACE ELEMENT","cancel":"Cancel","use":"Use","add":"Add","parent":"Parent","cancel_element_selection":"Cancel element selection","select_parent_element":"Select parent element","css_selector":"CSS selector","use_current_selector":"Use current selector","element":"ELEMENT","path":"PATH","selector":"SELECTOR","visible":"VISIBLE","hidden":"HIDDEN","fallback":"FALLBACK","automatically_placed":"Automatically placed by AdSense Auto ads code"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ad-inserter-pro/includes/js/ai-jquery.js?x21354&amp;ver=5.3.2+2.6.5'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-gdpr.min.js?x21354&amp;ver=2.1.4'></script>
<link rel='https://api.w.org/' href='https://rpgamer.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://rpgamer.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://rpgamer.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Pokémon Mystery Dungeon: Rescue Team DX Out Now' href='https://rpgamer.com/2020/03/pokemon-mystery-dungeon-rescue-team-dx-out-now/' />
<link rel='next' title='RPGamer Round-Up: March 1 – March 8' href='https://rpgamer.com/2020/03/rpgamer-round-up-march-1-march-8/' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://rpgamer.com/?p=68157' />
<link rel="alternate" type="application/json+oembed" href="https://rpgamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frpgamer.com%2F2020%2F03%2Frpg-cast-episode-534-dr-thunder-fallout%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://rpgamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Frpgamer.com%2F2020%2F03%2Frpg-cast-episode-534-dr-thunder-fallout%2F&#038;format=xml" />
<script type="text/javascript"><!--
function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}
//-->
</script>
		<style type="text/css">
			.request_name {
				display: none !important;
			}
		</style>
	<meta name="copyright" content="Copyright (c)1998-2018 RPGamer. All Rights Reserved.">
<meta name="keywords" content="RPGs, video games, RPGamer, Switch, PS4, Vita, Xbox One, PC,reviews, news, features, editorials">
<meta name="twitter:card" content="summary">
<meta name="twitter:site" content="@RPGamer">
<meta property="og:site_name" content="RPGamer">
<meta name="description" content="We missed you all last week, but we’re back with a bunch of hot topics, including the FF7R demo, Dragon Quest of the Stars, and which alien Kelley got busy with in Mass Effect.  Anna Marie gets really confused about review scores, and we can’t really decide when a Millennial starts and a Gen-X ends.  Of course, none of that matters because Animal Crossing is almost here!">
<meta property="og:description" content="We missed you all last week, but we’re back with a bunch of hot topics, including the FF7R demo, Dragon Quest of the Stars, and which alien Kelley got busy with in Mass Effect.  Anna Marie gets really confused about review scores, and we can’t really decide when a Millennial starts and a Gen-X ends.  Of course, none of that matters because Animal Crossing is almost here!">
<meta property="og:image" content="https://rpgamer.com/wp-content/uploads/2017/10/RPGCast.jpg">
<meta property="twitter:image" content="https://rpgamer.com/wp-content/uploads/2017/10/RPGCast.jpg">
<!--[if lt IE 9]>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/html5shiv-printshiv.min.js?x21354"></script>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/selectivizr.js?x21354"></script>
<![endif]-->
<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style><link rel="icon" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-32x32.png?x21354" sizes="32x32" />
<link rel="icon" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-192x192.png?x21354" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-180x180.png?x21354" />
<meta name="msapplication-TileImage" content="https://rpgamer.com/wp-content/uploads/2019/11/cropped-rpgamer-logo-270x270.png" />
<style>
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<!-- Google Tag Manager -->
    <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-M43VZB2');</script>
<!-- End Google Tag Manager -->
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-69178-8"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-69178-8');
</script>
<!-- NetworkN CMP Tool -->
<script>window.__cmp={config:{globalVendorListLocation:'https://cmp.network-n.com/vendorlist.json'}};</script>
<script src="https://cmp.network-n.com/js/cmp.complete.bundle.js" async></script></head>

<body class="post-template-default single single-post postid-68157 single-format-standard wp-embed-responsive col-2cl full-width topbar-enabled header-desktop-sticky header-mobile-sticky unknown">
<div id="wrapper">
  <a class="screen-reader-text skip-link" href="#content">Skip to content</a>
  <div class="widget-extra-header-widget"><div class="widget-extra-header-widget-inner"><div class='code-block code-block-1' style='text-align: center; clear: both;'>
<div id="nn_lb1"></div></div>
</div></div>
  <header id="header" class="specific-mobile-menu-on one-mobile-menu mobile_menu header-ads-desktop header-ads-mobile  no-header-img">
        <nav class="nav-container group mobile-menu mobile-sticky " id="nav-mobile" data-menu-id="header-1">
  <div class="mobile-title-logo-in-header"></div>
        
                    <!-- <div class="ham__navbar-toggler collapsed" aria-expanded="false">
          <div class="ham__navbar-span-wrapper">
            <span class="ham-toggler-menu__span"></span>
          </div>
        </div> -->
        <button class="ham__navbar-toggler-two collapsed" title="Menu" aria-expanded="false">
          <span class="ham__navbar-span-wrapper">
            <span class="line line-1"></span>
            <span class="line line-2"></span>
            <span class="line line-3"></span>
          </span>
        </button>
            
      <div class="nav-text"></div>
      <div class="nav-wrap container">
                  <ul class="nav container-inner group mobile-search">
                            <li>
                  <form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </li>
                      </ul>
                <ul id="menu-topbear" class="nav container-inner group"><li id="menu-item-103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103"><a href="/">Home</a></li>
<li id="menu-item-18160" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18160"><a href="/review/">Reviews</a>
<ul class="sub-menu">
	<li id="menu-item-18089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18089"><a href="/review">Review Archive</a></li>
	<li id="menu-item-18090" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18090"><a href="https://rpgamer.com/category/reviews/">Latest Reviews</a></li>
	<li id="menu-item-40189" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40189"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li id="menu-item-62274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62274"><a href="https://rpgamer.com/category/deep-looks/">Deep Looks</a></li>
</ul>
</li>
<li id="menu-item-87" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87"><a href="https://rpgamer.com/category/features/">Features</a>
<ul class="sub-menu">
	<li id="menu-item-786" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-786"><a href="https://rpgamer.com/category/features/interviews/">Interviews</a></li>
	<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://rpgamer.com/category/impressions/">Impressions</a></li>
	<li id="menu-item-52009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52009"><a href="https://rpgamer.com/category/features/editorials/">Editorials</a></li>
	<li id="menu-item-8195" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8195"><a href="https://rpgamer.com/category/features/awards/">Awards</a></li>
	<li id="menu-item-62275" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62275"><a href="https://rpgamer.com/category/adventure-corner/">Adventure Corner</a></li>
	<li id="menu-item-8252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8252"><a href="https://rpgamer.com/category/features/special-features/">Special Features</a></li>
</ul>
</li>
<li id="menu-item-88" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88"><a href="https://rpgamer.com/category/news/">News</a></li>
<li id="menu-item-318" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-318"><a href="/discord">Community</a>
<ul class="sub-menu">
	<li id="menu-item-26116" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26116"><a href="/discord">Discord</a></li>
	<li id="menu-item-26117" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26117"><a href="http://forums.rpgamer.com/">Forums</a></li>
</ul>
</li>
<li id="menu-item-276" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-276"><a href="https://rpgamer.com/category/podcasts/">Podcasts</a>
<ul class="sub-menu">
	<li id="menu-item-280" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-280"><a href="https://rpgamer.com/category/podcasts/rpgcast/">RPG Cast</a></li>
	<li id="menu-item-279" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279"><a href="https://rpgamer.com/category/podcasts/backtrack/">RPG Backtrack</a></li>
	<li id="menu-item-278" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-278"><a href="https://rpgamer.com/category/podcasts/qaquest/">Q&#038;A Quest</a></li>
	<li id="menu-item-277" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277"><a href="https://rpgamer.com/category/podcasts/atbs/">Active Topical Banter Show</a></li>
	<li id="menu-item-21054" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21054"><a href="https://rpgamer.com/category/podcasts/thehunt/">The Hunt</a></li>
</ul>
</li>
<li id="menu-item-17948" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17948"><a href="/platform/">Games</a>
<ul class="sub-menu">
	<li id="menu-item-17949" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17949"><a href="/platform/ps4">PlayStation 4</a></li>
	<li id="menu-item-17950" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17950"><a href="/platform/xbone">Xbox One</a></li>
	<li id="menu-item-17951" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17951"><a href="/platform/nsw">Nintendo Switch</a></li>
	<li id="menu-item-17952" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17952"><a href="/platform/win">PC</a></li>
	<li id="menu-item-17953" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17953"><a href="/platform/vita">PlayStation Vita</a></li>
	<li id="menu-item-17963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17963"><a href="https://rpgamer.com/platform/">Other Platforms</a></li>
</ul>
</li>
<li id="menu-item-299" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-299"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a>
<ul class="sub-menu">
	<li id="menu-item-303" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-303"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a></li>
	<li id="menu-item-301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-301"><a href="https://rpgamer.com/about-rpgamer/current-staff/">Current Staff</a></li>
	<li id="menu-item-300" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300"><a href="https://rpgamer.com/about-rpgamer/indie-submissions/">Indie Submissions</a></li>
	<li id="menu-item-880" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li id="menu-item-879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-879"><a href="https://rpgamer.com/about-rpgamer/job-openings/">Job Openings</a></li>
	<li id="menu-item-30001" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30001"><a href="https://rpgamer.com/site-quotes/">Site Quotes</a></li>
	<li id="menu-item-30318" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30318"><a href="https://rpgamer.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li id="menu-item-18213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18213"><a href="https://rpgamer.com/login/">Login</a>
<ul class="sub-menu">
	<li id="menu-item-21988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21988"><a href="https://rpgamer.com/register/">Register</a></li>
</ul>
</li>
</ul>      </div>
</nav><!--/#nav-topbar-->  
        <nav class="nav-container group desktop-menu desktop-sticky " id="nav-topbar" data-menu-id="header-2">
    <div class="nav-text"></div>
  <div class="topbar-toggle-down">
    <i class="fas fa-angle-double-down" aria-hidden="true" data-toggle="down" title="Expand menu"></i>
    <i class="fas fa-angle-double-up" aria-hidden="true" data-toggle="up" title="Collapse menu"></i>
  </div>
  <div class="nav-wrap container">
    <ul id="menu-topbear-1" class="nav container-inner group"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-103"><a href="/">Home</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-18160"><a href="/review/">Reviews</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-18089"><a href="/review">Review Archive</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-18090"><a href="https://rpgamer.com/category/reviews/">Latest Reviews</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-40189"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62274"><a href="https://rpgamer.com/category/deep-looks/">Deep Looks</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-87"><a href="https://rpgamer.com/category/features/">Features</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-786"><a href="https://rpgamer.com/category/features/interviews/">Interviews</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-85"><a href="https://rpgamer.com/category/impressions/">Impressions</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-52009"><a href="https://rpgamer.com/category/features/editorials/">Editorials</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8195"><a href="https://rpgamer.com/category/features/awards/">Awards</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-62275"><a href="https://rpgamer.com/category/adventure-corner/">Adventure Corner</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8252"><a href="https://rpgamer.com/category/features/special-features/">Special Features</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-88"><a href="https://rpgamer.com/category/news/">News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-318"><a href="/discord">Community</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26116"><a href="/discord">Discord</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-26117"><a href="http://forums.rpgamer.com/">Forums</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-276"><a href="https://rpgamer.com/category/podcasts/">Podcasts</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-280"><a href="https://rpgamer.com/category/podcasts/rpgcast/">RPG Cast</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-279"><a href="https://rpgamer.com/category/podcasts/backtrack/">RPG Backtrack</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-278"><a href="https://rpgamer.com/category/podcasts/qaquest/">Q&#038;A Quest</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-277"><a href="https://rpgamer.com/category/podcasts/atbs/">Active Topical Banter Show</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21054"><a href="https://rpgamer.com/category/podcasts/thehunt/">The Hunt</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-17948"><a href="/platform/">Games</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17949"><a href="/platform/ps4">PlayStation 4</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17950"><a href="/platform/xbone">Xbox One</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17951"><a href="/platform/nsw">Nintendo Switch</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17952"><a href="/platform/win">PC</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17953"><a href="/platform/vita">PlayStation Vita</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17963"><a href="https://rpgamer.com/platform/">Other Platforms</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-299"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-303"><a href="https://rpgamer.com/about-rpgamer/">About RPGamer</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-301"><a href="https://rpgamer.com/about-rpgamer/current-staff/">Current Staff</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-300"><a href="https://rpgamer.com/about-rpgamer/indie-submissions/">Indie Submissions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-880"><a href="https://rpgamer.com/about-rpgamer/review-score-definitions/">Review Score Definitions</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-879"><a href="https://rpgamer.com/about-rpgamer/job-openings/">Job Openings</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30001"><a href="https://rpgamer.com/site-quotes/">Site Quotes</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-30318"><a href="https://rpgamer.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-18213"><a href="https://rpgamer.com/login/">Login</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21988"><a href="https://rpgamer.com/register/">Register</a></li>
</ul>
</li>
</ul>  </div>
      <div id="topbar-header-search" class="container">
      <div class="container-inner">
        <button class="toggle-search"><i class="fas fa-search"></i></button>
        <div class="search-expand">
          <div class="search-expand-inner"><form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div>
        </div>
      </div><!--/.container-inner-->
    </div><!--/.container-->
  
</nav><!--/#nav-topbar-->  
  <div class="container group">
        <div class="container-inner">

                    <div class="group pad central-header-zone">
                  <div class="logo-tagline-group">
                                                              </div>

                                </div>
      
      
    </div><!--/.container-inner-->
      </div><!--/.container-->

</header><!--/#header-->
  
  <div class="container" id="page">
    <div class="container-inner">
            <div class="main">
        <div class="main-inner group">
          
              <section class="content">
              <div class="page-title pad group">
          	    		<ul class="meta-single group">
    			<li class="category"><a href="https://rpgamer.com/category/news/" rel="category tag">News</a> <span>/</span> <a href="https://rpgamer.com/category/podcasts/" rel="category tag">Podcasts</a> <span>/</span> <a href="https://rpgamer.com/category/podcasts/rpgcast/" rel="category tag">RPG Cast</a></li>
    			    		</ul>

    	
    </div><!--/.page-title-->
          <div class="pad group">
              <article class="post-68157 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-podcasts category-rpgcast tag-final-fantasy-vii-remake">
    <div class="post-inner group">

      <h1 class="post-title entry-title">RPG Cast &#8211; Episode 534: &#8220;Dr. Thunder Fallout&#8221;</h1>
<p class="post-byline">
   by   <span class="vcard author">
     <span class="fn"><a href="https://rpgamer.com/author/sabin/" title="Posts by Chris Privitere" rel="author">Chris Privitere</a></span>
   </span>
   &middot;
                                <time class="published" datetime="2020-03-07T14:26:43-08:00">March 7, 2020</time>
              </p>
                                
      <div class="clear"></div>

      <div class="entry themeform">
        <div class="entry-inner">
          <p>We missed you all last week, but we’re back with a bunch of hot topics, including the FF7R demo, Dragon Quest of the Stars, and which alien Kelley got busy with in Mass Effect.  Anna Marie gets really confused about review scores, and we can’t really decide when a Millennial starts and a Gen-X ends.  Of course, none of that matters because Animal Crossing is almost here!</p>
<p><strong>Question of the Week</strong><br />
Are you going to get Animal Crossing?</p>
<p><a href="https://docs.google.com/spreadsheets/d/1hLXOun1ZxUP6E_vRgsLTdrSzy7q-h4iCHJt3EDYuKRs/edit?usp=sharing" rel="noopener noreferrer" target="_blank">Check out the show notes here!</a></p>
<div class="powerpress_player" id="powerpress_player_7628"><!--[if lt IE 9]><script>document.createElement('audio');</script><![endif]-->
<audio class="wp-audio-shortcode" id="audio-68157-1" preload="none" style="width: 100%;" controls="controls"><source type="audio/mpeg" src="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast534.mp3?_=1" /><a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast534.mp3">https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast534.mp3</a></audio></div><p class="powerpress_links powerpress_links_mp3">Podcast: <a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast534.mp3" class="powerpress_link_pinw" target="_blank" title="Play in new window" onclick="return powerpress_pinw('https://rpgamer.com/?powerpress_pinw=68157-podcast');" rel="nofollow">Play in new window</a> | <a href="https://dts.podtrac.com/redirect.mp3/rpgamer.nyc3.cdn.digitaloceanspaces.com/podcasts/rpgcast/rpgcast534.mp3" class="powerpress_link_d" title="Download" rel="nofollow" download="rpgcast534.mp3">Download</a></p><p class="powerpress_links powerpress_subscribe_links">Subscribe: <a href="https://podcasts.apple.com/podcast/rpg-cast/id264306390?mt=2&amp;ls=1" class="powerpress_link_subscribe powerpress_link_subscribe_itunes" title="Subscribe on Apple Podcasts" rel="nofollow">Apple Podcasts</a> | <a href="http://subscribeonandroid.com/feeds.feedburner.com/Rpgcast" class="powerpress_link_subscribe powerpress_link_subscribe_android" title="Subscribe on Android" rel="nofollow">Android</a> | <a href="https://www.google.com/podcasts?feed=aHR0cDovL2ZlZWRzLmZlZWRidXJuZXIuY29tL1JwZ2Nhc3Q" class="powerpress_link_subscribe powerpress_link_subscribe_googleplay" title="Subscribe on Google Podcasts" rel="nofollow">Google Podcasts</a> | <a href="https://www.stitcher.com/podcast/rpg-cast" class="powerpress_link_subscribe powerpress_link_subscribe_stitcher" title="Subscribe on Stitcher" rel="nofollow">Stitcher</a> | <a href="http://feeds.feedburner.com/Rpgcast" class="powerpress_link_subscribe powerpress_link_subscribe_rss" title="Subscribe via RSS" rel="nofollow">RSS</a></p><input class="fooboxshare_post_id" type="hidden" value="68157"/>          <nav class="pagination group">
                      </nav><!--/.pagination-->
        </div>

        
        <div class="clear"></div>
      </div><!--/.entry-->

    </div><!--/.post-inner-->
  </article><!--/.post-->

<div class="clear"></div>

<p class="post-tags"><span>Tags:</span> <a href="https://rpgamer.com/tag/final-fantasy-vii-remake/" rel="tag">Final Fantasy VII Remake</a></p>




<h4 class="heading">
	<i class="far fa-hand-point-right"></i>You may also like...</h4>

<ul class="related-posts group">

		<li class="related post-hover">
		<article class="post-64886 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-final-fantasy tag-final-fantasy-vii tag-final-fantasy-vii-remake tag-ps4 tag-square-enix">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2020/01/final-fantasy-vii-remake-pushed-to-april/">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2019/11/final-fantasy-vii-remake_2019-11-25_009-520x200.jpg?x21354"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2020/01/final-fantasy-vii-remake-pushed-to-april/" rel="bookmark" title="Permalink to Final Fantasy VII Remake Pushed to April">Final Fantasy VII Remake Pushed to April</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2020-01-14 08:57:41">January 14, 2020</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/severinmira/" title="Posts by Alex Fuller" rel="author">Alex Fuller</a></span>
    </span> &middot; Published <span class="published">January 14, 2020</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-49934 post type-post status-publish format-standard has-post-thumbnail hentry category-e3 category-news tag-e3-2019 tag-final-fantasy tag-final-fantasy-vii tag-final-fantasy-vii-remake tag-ps4 tag-square-enix">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2019/06/extended-final-fantasy-vii-remake-trailer-shows-tifa/">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2019/06/final-fantasy-vii-remake_2019-06-11_001-520x200.jpg?x21354"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2019/06/extended-final-fantasy-vii-remake-trailer-shows-tifa/" rel="bookmark" title="Permalink to Extended Final Fantasy VII Remake Trailer Shows Tifa">Extended Final Fantasy VII Remake Trailer Shows Tifa</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2019-06-11 06:41:51">June 11, 2019</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/severinmira/" title="Posts by Alex Fuller" rel="author">Alex Fuller</a></span>
    </span> &middot; Published <span class="published">June 11, 2019</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		<li class="related post-hover">
		<article class="post-66917 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-final-fantasy tag-final-fantasy-vii tag-final-fantasy-vii-remake tag-ps4 tag-square-enix">

			<div class="post-thumbnail">
				<a href="https://rpgamer.com/2020/02/more-final-fantasy-vii-remake-screenshots-show-multiple-elements/">
					<img  width="520" height="200"  src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-src="https://rpgamer.com/wp-content/uploads/2020/02/final-fantasy-vii-remake_2020-02-13_015-520x200.jpg?x21354"  class="attachment-thumb-medium size-thumb-medium wp-post-image" alt="" />																			</a>
							</div><!--/.post-thumbnail-->

			<div class="related-inner">

				<h4 class="post-title entry-title">
					<a href="https://rpgamer.com/2020/02/more-final-fantasy-vii-remake-screenshots-show-multiple-elements/" rel="bookmark" title="Permalink to More Final Fantasy VII Remake Screenshots Show Multiple Elements">More Final Fantasy VII Remake Screenshots Show Multiple Elements</a>
				</h4><!--/.post-title-->

				<div class="post-meta group">
					<p class="post-date">
  <time class="published updated" datetime="2020-02-13 13:02:54">February 13, 2020</time>
</p>

  <p class="post-byline" style="display:none">&nbsp;by    <span class="vcard author">
      <span class="fn"><a href="https://rpgamer.com/author/severinmira/" title="Posts by Alex Fuller" rel="author">Alex Fuller</a></span>
    </span> &middot; Published <span class="published">February 13, 2020</span>
      </p>
				</div><!--/.post-meta-->

			</div><!--/.related-inner-->

		</article>
	</li><!--/.related-->
		
</ul><!--/.post-related-->



<section id="comments" class="themeform">

	
					<!-- comments open, no comments -->
		
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/03/rpg-cast-episode-534-dr-thunder-fallout/?utm_source=feedburner&amp;utm_medium=feed&amp;utm_campaign=Feed%3A+Rpgcast+%28RPG+Cast%29#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in">You must be <a href="https://rpgamer.com/login/?redirect_to=https%3A%2F%2Frpgamer.com%2F2020%2F03%2Frpg-cast-episode-534-dr-thunder-fallout%2F">logged in</a> to post a comment.</p>	</div><!-- #respond -->
	
</section><!--/#comments-->          </div><!--/.pad-->
			        </section><!--/.content-->
          

	<div class="sidebar s1 collapsed" data-position="right" data-layout="col-2cl" data-sb-id="s1">

		<button class="sidebar-toggle" title="Expand Sidebar"><i class="fas sidebar-toggle-arrows"></i></button>

		<div class="sidebar-content">

			           			<div class="sidebar-top group">
                        <p>Follow:</p>          
          <ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/RPGamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/RPGamer/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Youtube" aria-label="Follow us on Youtube" href="https://www.youtube.com/user/RPGamerdotcom" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-youtube"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitch" aria-label="Follow us on Twitch" href="https://www.twitch.tv/rpgamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitch"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="/feed/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul>  			</div>
			
				<ul class="post-nav group">
		<li class="next"><a href="https://rpgamer.com/2020/03/rpgamer-round-up-march-1-march-8/" rel="next"><i class="fas fa-chevron-right"></i><strong>Next story</strong> <span>RPGamer Round-Up: March 1 – March 8</span></a></li>
		<li class="previous"><a href="https://rpgamer.com/2020/03/pokemon-mystery-dungeon-rescue-team-dx-out-now/" rel="prev"><i class="fas fa-chevron-left"></i><strong>Previous story</strong> <span>Pokémon Mystery Dungeon: Rescue Team DX Out Now</span></a></li>
	</ul>

			
			<div id="text-3" class="widget widget_text">			<div class="textwidget"><p>Welcome to RPGamer new site, which launched in 2018. Due to the wholesale change in our back-end and systems only content created from 2018 onwards has been carried over to our new site. However, all of our older content can still be found at <a href="http://archive.rpgamer.com">archive.rpgamer.com</a>.</p>
<p>RPGamer is pleased to announce that we are now listed on <a href="https://opencritic.com" target="_blank" rel="noopener noreferrer">OpenCritic</a>.</p>
</div>
		</div><div id="ai_widget-4" class="widget ai_widget"><div class='code-block code-block-3' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div id="nn_mpu1"></div></div>
</div><div id="search-2" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://rpgamer.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="alxposts-7" class="widget widget_hu_posts">
<h3 class="widget-title">Featured Posts</h3>
	
	<ul class="alx-posts group ">
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/03/whatcha-playing-january-february-2020/" rel="bookmark" title="Permalink to Whatcha Playing: January/February 2020">Whatcha Playing: January/February 2020</a></p>
				<p class="post-item-date">6 Mar, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/langrisser-i-ii-review/" rel="bookmark" title="Permalink to Langrisser I &#038; II Review">Langrisser I &#038; II Review</a></p>
				<p class="post-item-date">5 Mar, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/03/adventure-corner-takeshi-hiroshi/" rel="bookmark" title="Permalink to Adventure Corner: Takeshi &#038; Hiroshi">Adventure Corner: Takeshi &#038; Hiroshi</a></p>
				<p class="post-item-date">4 Mar, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/03/dragon-quest-your-story-netflix-review/" rel="bookmark" title="Permalink to Dragon Quest: Your Story Netflix Review">Dragon Quest: Your Story Netflix Review</a></p>
				<p class="post-item-date">3 Mar, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/hero-must-die-again-review/" rel="bookmark" title="Permalink to Hero Must Die. Again Review">Hero Must Die. Again Review</a></p>
				<p class="post-item-date">26 Feb, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/2020/02/adventure-corner-guildlings/" rel="bookmark" title="Permalink to Adventure Corner: Guildlings">Adventure Corner: Guildlings</a></p>
				<p class="post-item-date">26 Feb, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/paranoia-happiness-is-mandatory-review/" rel="bookmark" title="Permalink to Paranoia:  Happiness Is Mandatory Review">Paranoia:  Happiness Is Mandatory Review</a></p>
				<p class="post-item-date">25 Feb, 2020</p>			</div>

		</li>
				<li>

			
			<div class="post-item-inner group">
								<p class="post-item-title"><a href="https://rpgamer.com/review/romancing-saga-3-review/" rel="bookmark" title="Permalink to Romancing SaGa 3 Review">Romancing SaGa 3 Review</a></p>
				<p class="post-item-date">24 Feb, 2020</p>			</div>

		</li>
					</ul><!--/.alx-posts-->

</div>
<div id="released_widget-4" class="widget widget_released_widget"><h3 class="widget-title">Recent Releases</h3><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.06</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/pokemon-mystery-dungeon-rescue-team-dx/'>Pokémon Mystery Dungeon: Rescue Team DX</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.04</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/castlevania-symphony-of-the-night/'>Castlevania: Symphony of the Night</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.01</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/steamworld-quest-hand-of-gilgamech/'>SteamWorld Quest: Hand of Gilgamech</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2019/11/google-stadia-icon.png?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.28</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/ganbare-super-strikers/'>Ganbare! Super Strikers</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.27</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/hero-must-die/'>Hero Must Die</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.26</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/ganbare-super-strikers/'>Ganbare! Super Strikers</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/xbone.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.26</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/yakuza-zero/'>Yakuza Zero</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/xbone.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.26</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/hero-must-die/'>Hero Must Die</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.25</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/ganbare-super-strikers/'>Ganbare! Super Strikers</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>02.25</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/wasteland-remastered/'>Wasteland Remastered</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div></div><div id="upcoming_widget-4" class="widget widget_upcoming_widget"><h3 class="widget-title">Upcoming Releases</h3><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.10</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/langrisser-i-ii-remake/'>Langrisser I &amp; II Remake</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.13</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/alders-blood/'>Alder's Blood</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ns-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.13</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/nioh-2/'>Nioh 2</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ps4-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.17</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/pillars-of-dust/'>Pillars of Dust</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/win-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.23</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/the-legend-of-heroes-trails-of-cold-steel-iii/'>The Legend of Heroes: Trails of Cold Steel III</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/win-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.24</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/element-space/'>Element: Space</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.25</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/iron-danger/'>Iron Danger</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/win-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.31</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/operencia-the-stolen-sun/'>Operencia: The Stolen Sun</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/12/multi.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>03.31</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/persona-5-royal/'>Persona 5 Royal</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/ps4-1.gif?x21354"></div></div><div class = 'sidebar_releases'><div class = 'si_rel_date'>04.02</div><div class = 'si_rel_game_name'><a href = 'https://rpgamer.com/game/sometimes-always-monsters/'>Sometimes Always Monsters</a></div><div class = 'si_rel_platform'><img class = "si_rel_plat_icon" src="//rpgamer.com/wp-content/uploads/2017/10/win-1.gif?x21354"></div></div></div><div id="custom_html-27" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align:center;"><a href="/platform/">See All Releases</a></div></div></div><div id="custom_html-33" class="widget_text widget widget_custom_html"><h3 class="widget-title">Reader Poll</h3><div class="textwidget custom-html-widget"><script type="text/javascript" charset="utf-8" src="https://secure.polldaddy.com/p/10506059.js"></script>
<noscript><a href="https://poll.fm/10506059">What sort of active party size do you generally prefer having in an RPG?</a></noscript></div></div><div id="custom_html-39" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div style="text-align: center;">

		<a href="http://rpgamer.com/discord/" target="_blank" rel="noopener noreferrer">Join the dicussion on Discord.</a></div>
	</div></div><div id="recent-comments-2" class="widget widget_recent_comments"><h3 class="widget-title">Recent Comments</h3><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/jscarpe/">jscarpe</a></span> on <a href="https://rpgamer.com/2020/03/whatcha-playing-january-february-2020/#comment-2052">Whatcha Playing: January/February 2020</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/ichiroku/">Ichiroku</a></span> on <a href="https://rpgamer.com/2020/03/trials-of-mana-gets-new-gameplay-trailer-screenshots/#comment-2051">Trials of Mana Gets New Gameplay Trailer, Screenshots</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/aeramis/">Aeramis</a></span> on <a href="https://rpgamer.com/review/langrisser-i-ii-review/#comment-2050">Langrisser I &#038; II Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/severinmira/">severinmira</a></span> on <a href="https://rpgamer.com/2020/03/episode-152-electric-boogaloo-qa-quest/#comment-2049">Episode 152: Electric Boogaloo &#8211; Q&#038;A Quest</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/krull/">Krull</a></span> on <a href="https://rpgamer.com/2020/03/episode-152-electric-boogaloo-qa-quest/#comment-2048">Episode 152: Electric Boogaloo &#8211; Q&#038;A Quest</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/krull/">Krull</a></span> on <a href="https://rpgamer.com/2020/03/episode-152-electric-boogaloo-qa-quest/#comment-2047">Episode 152: Electric Boogaloo &#8211; Q&#038;A Quest</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/scar/">Scar</a></span> on <a href="https://rpgamer.com/2020/03/trials-of-mana-gets-new-gameplay-trailer-screenshots/#comment-2046">Trials of Mana Gets New Gameplay Trailer, Screenshots</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/jcservant/">JCServant</a></span> on <a href="https://rpgamer.com/2020/03/whatcha-playing-january-february-2020/#comment-2045">Whatcha Playing: January/February 2020</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/ichiroku/">Ichiroku</a></span> on <a href="https://rpgamer.com/review/langrisser-i-ii-review/#comment-2044">Langrisser I &#038; II Review</a></li><li class="recentcomments"><span class="comment-author-link"><a href="https://rpgamer.com/user/aeramis/">Aeramis</a></span> on <a href="https://rpgamer.com/review/langrisser-i-ii-review/#comment-2043">Langrisser I &#038; II Review</a></li></ul></div>
		</div><!--/.sidebar-content-->

	</div><!--/.sidebar-->

	

        </div><!--/.main-inner-->
      </div><!--/.main-->
    </div><!--/.container-inner-->
  </div><!--/.container-->
  <div class="widget-extra-footer-widget"><div class="widget-extra-footer-widget-inner"><div class='code-block code-block-2' style='text-align: center; clear: both;'>
<div id="nn_lb2"></div></div>
</div></div>  <footer id="footer">

    
    
    
    <section class="container" id="footer-bottom">
      <div class="container-inner">

        <a id="back-to-top" href="#"><i class="fas fa-angle-up"></i></a>

        <div class="pad group">

          <div class="grid one-half">
                        
            <div id="copyright">
                <p></p>
            </div><!--/#copyright-->

            
          </div>

          <div class="grid one-half last">
                          <ul class="social-links"><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitter" aria-label="Follow us on Twitter" href="https://twitter.com/RPGamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitter"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Facebook" aria-label="Follow us on Facebook" href="https://www.facebook.com/RPGamer/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-facebook"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Youtube" aria-label="Follow us on Youtube" href="https://www.youtube.com/user/RPGamerdotcom" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-youtube"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Twitch" aria-label="Follow us on Twitch" href="https://www.twitch.tv/rpgamer" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fab fa-twitch"></i></a></li><li><a rel="nofollow noopener noreferrer" class="social-tooltip"  title="Follow us on Rss" aria-label="Follow us on Rss" href="/feed/" target="_blank"  style="color:rgba(255,255,255,0.7)"><i class="fas fa-rss"></i></a></li></ul>                      </div>

        </div><!--/.pad-->

      </div><!--/.container-inner-->
    </section><!--/.container-->

  </footer><!--/#footer-->

</div><!--/#wrapper-->

<div class='ai-viewports ai-viewport-1 ai-insert-4-31907481' data-insertion='after' data-selector='.ai-insert-4-31907481' data-insertion-no-dbg data-code='PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTQnIHN0eWxlPScnPgo8ZGl2IGlkPSJubl9za2lubCI+PC9kaXY+PC9kaXY+Cg==' data-block='4'></div>

<div class='ai-viewports ai-viewport-1 ai-insert-5-93206134' data-insertion='after' data-selector='.ai-insert-5-93206134' data-insertion-no-dbg data-code='PGRpdiBjbGFzcz0nY29kZS1ibG9jayBjb2RlLWJsb2NrLTUnIHN0eWxlPScnPgo8ZGl2IGlkPSJubl9za2luciI+PC9kaXY+PC9kaXY+Cg==' data-block='5'></div>


<div id="um_upload_single" style="display:none"></div>
<div id="um_view_photo" style="display:none">

	<a href="javascript:void(0);" data-action="um_remove_modal" class="um-modal-close"><i class="um-faicon-times"></i></a>

	<div class="um-modal-body photo">
		<div class="um-modal-photo"></div>
	</div>

</div><link rel='stylesheet' id='mediaelement-css'  href='https://rpgamer.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?x21354&amp;ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://rpgamer.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?x21354&amp;ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/underscore.min.js?x21354&amp;ver=1.8.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var HUParams = {"_disabled":[],"SmoothScroll":{"Enabled":true,"Options":{"touchpadSupport":false}},"centerAllImg":"1","timerOnScrollAllBrowsers":"1","extLinksStyle":"","extLinksTargetExt":"","extLinksSkipSelectors":{"classes":["btn","button"],"ids":[]},"imgSmartLoadEnabled":"1","imgSmartLoadOpts":{"parentSelectors":[".container .content",".container .sidebar","#footer","#header-widgets"],"opts":{"excludeImg":[".tc-holder-img"],"fadeIn_options":100}},"goldenRatio":"1.618","gridGoldenRatioLimit":"350","sbStickyUserSettings":{"desktop":false,"mobile":true},"sidebarOneWidth":"340","sidebarTwoWidth":"260","isWPMobile":"","menuStickyUserSettings":{"desktop":"stick_always","mobile":"stick_up"},"mobileSubmenuExpandOnClick":"","submenuTogglerIcon":"<i class=\"fas fa-angle-down\"><\/i>","isDevMode":"","ajaxUrl":"https:\/\/rpgamer.com\/?huajax=1","frontNonce":{"id":"HuFrontNonce","handle":"6914491cc0"},"isWelcomeNoteOn":"","welcomeContent":"","i18n":{"collapsibleExpand":"Expand","collapsibleCollapse":"Collapse"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/themes/hueman/assets/front/js/scripts.min.js?x21354&amp;ver=3.3.28.c1.8.0'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/comment-reply.min.js?x21354&amp;ver=5.3.2'></script>
<script type='text/javascript'>
/* Run FooBox (v2.7.8) */
var FOOBOX = window.FOOBOX = {
	ready: true,
	preloadFont: true,
	disableOthers: false,
	customOptions: {  },
	o: {wordpress: { enabled: true },
		pan: { enabled: true, showOverview: true, position: "fbx-top-right" },
		debug:true,
		deeplinking : { enabled: true, prefix: "foobox" },
		fullscreen : { enabled: true, useAPI: true },
		effect: 'fbx-effect-1',
		excludes:'.fbx-link,.nofoobox,.nolightbox,a[href*="pinterest.com/pin/create/button/"]',
		affiliate : { enabled: false },
		slideshow: { enabled:true},
		social: {"enabled":true,"position":"fbx-above","mailto":true,"download":true,"excludes":[],"nonce":"cc67812a8e","networks":["facebook","twitter","pinterest","tumblr","reddit"]},
		preload:true},
	selectors: [
		".gallery", ".wp-block-gallery", ".foogallery-container.foogallery-lightbox-foobox", ".foogallery-container.foogallery-lightbox-foobox-free", ".foobox, [target=\"foobox\"]", ".wp-caption", ".wp-block-image", "a:has(img[class*=wp-image-])"
	],
	pre: function( $ ){
		// Custom JavaScript (Pre)
		
	},
	post: function( $ ){
		// Custom JavaScript (Post)
		
		// Custom Captions Code
		
	},
	custom: function( $ ){
		// Custom Extra JS
		
	}
};
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/foobox-image-lightbox-premium/pro/js/foobox.debug.js?x21354&amp;ver=2.7.8'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/select2/select2.full.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/wp-util.min.js?x21354&amp;ver=5.3.2'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-crop.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-modal.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-jquery-form.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-fileupload.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.date.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/picker.time.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/pickadate/legacy.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?x21354&amp;ver=7.4.4'></script>
<script type='text/javascript'>
( 'fetch' in window ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?x21354&amp;ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?x21354&amp;ver=3.26.0-0"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?x21354&amp;ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://rpgamer.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?x21354&amp;ver=2.0.2"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/dist/i18n.min.js?x21354&amp;ver=3.6.1'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-raty.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-tipsy.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/imagesloaded.min.js?x21354&amp;ver=3.2.0'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/masonry.min.js?x21354&amp;ver=3.3.2'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/jquery/jquery.masonry.min.js?x21354&amp;ver=3.1.2b'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/simplebar.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-functions.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-responsive.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-conditional.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var um_scripts = {"nonce":"be92c1f1ff"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-scripts.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-profile.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/ultimate-member/assets/js/um-account.min.js?x21354&amp;ver=2.1.4'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/wp-embed.min.js?x21354&amp;ver=5.3.2'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-content/plugins/powerpress/player.min.js?x21354&amp;ver=5.3.2'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?x21354&amp;ver=4.2.13-9993131'></script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?x21354&amp;ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://rpgamer.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?x21354&amp;ver=5.3.2'></script>
<style type="text/css">

</style><!--[if lt IE 9]>
<script src="https://rpgamer.com/wp-content/themes/hueman/assets/front/js/ie/respond.js?x21354"></script>
<![endif]-->
<!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M43VZB2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) --><script>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</script>
		<script type="text/javascript">
			jQuery( '#request' ).val( '' );
		</script>
	</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 333/470 objects using memcached
Page Caching using memcached (Requested URI contains query) 
Database Caching 40/71 queries in 0.026 seconds using memcached

Served from: rpgamer.com @ 2020-03-08 15:42:09 by W3 Total Cache
-->